Vulnerabilidades en Iceweasel

noviembre 25, 2008

iceweasel

iceweasel

Los genios del Common Vulnerabilities and Exposures han descubierto múltiples vulnerabilidades en el navegador Iceweasel, la versión “sin marca registrada” de Mozilla Firefox que los chicos de Debian fabricaron para evitar dramas de licencias. La lista completa reza así:

  • Un desbordamiento del buffer en el analizador http-index-format puede permitir la ejecución de código arbitrario;
  • Se descubrió una fuga de información a través de los archivos de acceso al directorio local;
  • El elemento lienzo puede ser usado para eludir restricciones same-origin;
  • La falta de verificaciones en el código conector del plugin de Flash puede conducir a la ejecución de código arbitrario;
  • un error de programación en el objeto window.__proto__.__proto__ object puede conducir a la ejecución de código arbitrario.
  • Ha sido descubierto que bloqueos en el motor de diseño pueden conducir a la ejecución de código arbitrario.
  • Ha sido descubierto que bloqueos en el motor Javascript pueden conducir a la ejecución de código arbitrario.
  • Ha sido descubierto que un bloqueo en nsFrameManager podría conducir a la ejecución de código arbitrario.
  • Ha sido descubierto que la verificación same-origin nsXMLHttpRequest::NotifyEventListeners() puede ser eludida.
  • Ha sido descubierto que la propiedad -moz-binding elude las verificaciones de seguridad en las directivas del código base.
  • Ha sido descubierto que los caracteres de comillas son impropiamente escapados en el namespace por defecto de documentos E4X.

Ahora, no es necesario salir corriendo del sistema a bajarse una copia de algún otro sistema operativo más vulnerable, ya que todas estas fallas fueron corregidas, y puestas a disposición de la comunidad con la versión 2.0.0.18-0etch1 (versión que se está instalando por el sistema de actualización mientras escribo esto).

Para la próxima distribución estable (lenny) y la distribución inestable (sid), estos problemas han sido arreglados en la versión 3.0.4-1 de iceweasel y la versión 1.9.0.4-1 de xulrunner. Los paquetes para arm y mips serán distribuidos luego.

La recomendación, obvia por lo demás, es: actualizar.

Una respuesta to “Vulnerabilidades en Iceweasel”


  1. […] ckgni wrote an interesting post today onHere’s a quick excerpt […]


Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: